Can make a connection but after this nothing happens.

12 posts / 0 new
Last post
maikelhardenberg
Can make a connection but after this nothing happens.

Hi,
I am trying to get your software working.

I am able to connect the client to the server and click use device and it says the device is in use by me. But after that nothing happens, I do not see the device anywhere and I do not have any errors showing up.

Serverside:
Physical Machine
Windows server 2016 standard Version 1607
vhusbdwin64 version 3.8.1.0

Clientside:
Virtual machine (VMWare)
Windows server 2016 standard Version 1607
vhui64 version 4.6.4.0

If I connect a client from a windows 10 machine to the same windows 2016 server it works as expected.

Any ideas what might go wrong?

maikelhardenberg
Extra info

Normal usb stick works. In the above example i am using a SafeNet E token wich is not working.

Michael
.

I use a safenet token via virtualhere on win2016 when actually building and signing virtualhere for release so it definitely works.

But i am using KVM and i connect to the win2016 server via virt-manager which means im not using RDP. I think RDP might be blocking the token. Remote Desktop (RDP) sometimes does this for some tokens. In the RDP settings i thinking there might be a setting to not redirect tokens, can you check this. Also i connect to the root session of the win2016 server (as if someone was sitting in front of the monitor). A last resort might be to try connecting via VNC.

maikelhardenberg
.

I logged in trough the VMWare console now and then i do not use rdp either, unfortunatly the outcome is the same.

Michael
.

OK at the moment im on holidays for another week when i get back i will look into this issue.

maikelhardenberg
.

Ok, Thnx.

maikelhardenberg
.

Hi Michael,

Any progress about this issue?

Michael
.

Use the device via virtualhere. On the client machine open Device Manager and View->Devices by Connection->VirtualHere USB 3.0 Extensible Host Controller and then see if the device appears under there ok

maikelhardenberg
.

It does, it shows up as 'USB Token' and the properties - general tab says it is a Aladdin Knowledge Systems Ltd

Michael
.

OK it seems the device is appearing ok then and working and the driver binding. So im not sure whats wrong...I think something is blocking in in your windows setup. Can you double check you have the latest safenet drivers. otherwise im not sure of the issue unfortunately.

maikelhardenberg
.

Updated to the latest safenet drivers 10.6.115.0 and also made a change on VMware level.
Enable USB CCID Device Connection in VM

1. Shut-down the VM
2. VM > Edit settings > VM Options
3. Advanced > Configuration Parameters > Edit Configuration
4. + Add Parameter and add following Key and Value
usb.generic.allowCCID TRUE

Now when i logon in console mode in vmware the device works as expected. I need it to work when I logon from RDP but there i still have the same problem.

Michael
.

RDP is blocking it, you need to use vnc

Log in or register to post comments