Disappearing/Missing Dongles - Linux

4 posts / 0 new
Last post
dam0
Disappearing/Missing Dongles - Linux

Hi,
OK so we have been running a dongle server on Linux (debian VM) for a couple of years, rarely problems with maybe a good 8-12 dongles.
Mid last year, we seem to lose alot of the dongles, as in they were not visible from the Windows clients (VMs). After a reboot of the Linux system all was well.
But the last couple of months, things have been getting slowly worst. Currently problems:
1. We don't see all the dongles, maybe 4 out of a good 8.
2. I might restart the system and power off one of the USB hubs and we see maybe 6? But two days later some are not visible again.
I upgraded the Windows client, no difference.
3. It seems to get confused what dongle is which one (within brands). We have five (5) of one brand and it doesn't seem to know which one is which, especially if i have to move them. Do I need to power down, remove, power up, then add them one at a time? Or is this just a flow on effect of our bigger problem?

So, is there a log which might show errors? I'm guessing there is. (sorry more a wintel person)
Sorry what is the best way to upgrade the Linux server/daemon.

Thanks.
Damian.

Michael
.

1. You should not run virtualhere *server* inside a vm as virtualhere cannot directly access the usb devices and you might get weird errors like this. The virtualhere *client* is fine to run inside a vm.

2. Anyway if it was working fine and then slowly stopped working with no change in anything, then i think it might be a hardware issue. The log is in /var/log/syslog do this

grep vhusbd /var/log/syslog

and see what it says when the dongles disappear. It might be something like "SURPRISE UNBOUND" . If so the dongle is dropping by itself.

dam0
Restarted the system and got

Restarted the system and got the following messages:
Near the end is errors.

root@dongleserver:~# grep vhusbd /var/log/syslog
May 3 18:49:03 dongleserver vhusbdx86_64: >>> Starting v2.2.4 (Built: Apr 26 2015, 04:40:06)<<<
May 3 18:49:03 dongleserver vhusbdx86_64: Using default configuration /etc/init.d/config.ini
May 3 18:49:03 dongleserver vhusbdx86_64: Serial:564``````9B
May 3 18:49:03 dongleserver vhusbdx86_64: Server licensed to=564```````9B max_devices=unlimited
May 3 18:49:03 dongleserver vhusbdx86_64: Using large URB's
May 3 18:49:03 dongleserver vhusbdx86_64: TCPServer starting...
May 3 18:49:03 dongleserver vhusbdx86_64: Listening on all network interfaces at port 80
May 3 18:49:03 dongleserver vhusbdx86_64: Found Full speed device [0e0f:0003] "VMware, VMware Virtual USB Mouse" at address 11
May 3 18:49:03 dongleserver vhusbdx86_64: Found High speed device [090c:1000] "General, USB Flash Disk" at address 21
May 3 18:49:03 dongleserver vhusbdx86_64: Found High speed device [14cd:121f] "Generic, Mass Storage Device" at address 22
May 3 18:49:03 dongleserver vhusbdx86_64: Found Full speed device [096e:0006] "OEM, HID Dongle" at address 121
May 3 18:49:03 dongleserver vhusbdx86_64: Found Full speed device [064f:2af9] "WIBU-SYSTEMS AG, CodeMeter-Stick" at address 122
May 3 18:49:03 dongleserver vhusbdx86_64: Found Low speed device [0529:0001] "AKS, HASP HL 3.25" at address 123
May 3 18:49:03 dongleserver vhusbdx86_64: Found Full speed device [096e:0006] "OEM, HID Dongle" at address 126
May 3 18:49:03 dongleserver vhusbdx86_64: TCPServer (80) started
May 3 18:49:03 dongleserver vhusbdx86_64: >>> Starting v2.2.4 (Built: Apr 26 2015, 04:40:06)<<<
May 3 18:49:03 dongleserver vhusbdx86_64: Using default configuration /etc/init.d/config.ini
May 3 18:49:03 dongleserver vhusbdx86_64: Serial:564`````9B
May 3 18:49:03 dongleserver vhusbdx86_64: Server licensed to=564D`````B max_devices=unlimited
May 3 18:49:03 dongleserver vhusbdx86_64: Using large URB's
May 3 18:49:03 dongleserver vhusbdx86_64: TCPServer starting...
May 3 18:49:03 dongleserver vhusbdx86_64: Error 98 binding server socket to a listening address, Address in use
May 3 18:49:03 dongleserver vhusbdx86_64: Error starting server
May 3 18:49:03 dongleserver vhusbdx86_64: VirtualHere caught signal 11 (Segmentation fault) and must exit. Sorry for the inconvenience, please contact mail@virtualhere for help
May 3 18:49:03 dongleserver vhusbdx86_64[829]: VirtualHere caught signal 11 (Segmentation fault) and must exit. Sorry for the inconvenience, please contact mail@virtualhere for help
May 3 18:49:03 dongleserver systemd[1]: vhusbdx86_64.service: control process exited, code=killed status=11
May 3 18:49:03 dongleserver systemd[1]: Unit vhusbdx86_64.service entered failed state.
May 3 18:49:03 dongleserver vhusbdx86_64: Callback: #027VirtualHere USB Sharing#006_vhusb#004_tcp#005local Name Registered

Michael
.

Dont run it under vmware and update the server to 3.8.7 https://www.virtualhere.com/usb_server_software

Log in or register to post comments