Error connecting USB device to Linux server

8 posts / 0 new
Last post
drohm
Error connecting USB device to Linux server

Hi,
I'm running a linux server (haswell version) and when I try connecting my Garmin fenix 5S I'm getting the following warnings when I do a status on the service:

● virtualhere.service - VirtualHere USB Sharing
Loaded: loaded (/etc/systemd/system/virtualhere.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2019-07-17 22:32:00 EDT; 11h ago
Main PID: 1461 (vhusbdx86_64hw)
Tasks: 42 (limit: 4915)
Memory: 5.9M
CGroup: /system.slice/virtualhere.service
└─1461 /usr/bin/vhusbdx86_64hw

Jul 18 10:25:54 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Warning, could not open device product file /sys//devices/pci0000:00/0000:00:14.0/usb3/3-9/3-9.4/3-9.4.4/3-9.4.4.4/3-9.4.4.4.1/product, error 2 (No such file or directory)
Jul 18 10:25:54 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Found High speed device [091e:0003] "0x091e, 0x0003" at address 394441
Jul 18 10:26:01 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Unmanaging device 394441 [091e:0003]
Jul 18 10:26:03 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Warning, could not open device product file /sys//devices/pci0000:00/0000:00:14.0/usb3/3-9/3-9.4/3-9.4.4/3-9.4.4.4/3-9.4.4.4.1/product, error 2 (No such file or directory)
Jul 18 10:26:03 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Found High speed device [091e:4b54] "0x091e, 0x4b54" at address 394441
Jul 18 10:26:06 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Device 394441 [091e:4b54] BOUND to connection 1
Jul 18 10:27:59 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Device 394441 [091e:4b54] SURPRISE UNBOUND from connection 1
Jul 18 10:27:59 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Unmanaging device 394441 [091e:4b54]
Jul 18 10:28:34 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Warning, could not open device product file /sys//devices/pci0000:00/0000:00:14.0/usb3/3-9/3-9.4/3-9.4.4/3-9.4.4.4/3-9.4.4.4.1/product, error 2 (No such file or directory)
Jul 18 10:28:34 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Found High speed device [091e:0003] "0x091e, 0x0003" at address 394441

When I try using the client (Windows 10) it sees the device and allows me to use it, but the Garmin software won't detect it. I'm not sure where to go with this and any suggestions would be great. Let me know if you need me to post any other information I may have left out. Thanks.

Doug

Michael
.

It seems its loading firmware and switching from 091e:0003 to 091e:4b54 as the vendor id and product id. Im not sure this will be usable via virtualhere but we can try a few things.

Can you right click on the device in the VirtualHere Client and select Properties and see what the vendor id and product id is and note that, then right click on the Device again and select Custom Event Handler.. and paste in this line (dont change anything)

onReset.$VENDOR_ID$.$PRODUCT_ID$=

then press OK. Now unplug and replug the device and then try using via virtualhere.

drohm
Did as you said and then

Did as you said and then checked the status of the server (systemctl status virtualhere.service):

virtualhere.service - VirtualHere USB Sharing
Loaded: loaded (/etc/systemd/system/virtualhere.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2019-07-17 22:32:00 EDT; 21h ago
Main PID: 1461 (vhusbdx86_64hw)
Tasks: 39 (limit: 4915)
Memory: 6.9M
CGroup: /system.slice/virtualhere.service
└─1461 /usr/bin/vhusbdx86_64hw

Jul 18 20:09:44 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Found High speed device [091e:0003] "0x091e, 0x0003" at address 3944443
Jul 18 20:09:45 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Unmanaging device 3944443 [091e:0003]
Jul 18 20:09:53 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Warning, could not open device product file /sys//devices/pci0000:00/0000:00:1
Jul 18 20:09:53 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Found High speed device [091e:0003] "0x091e, 0x0003" at address 3944443
Jul 18 20:10:00 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Unmanaging device 3944443 [091e:0003]
Jul 18 20:10:02 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Warning, could not open device product file /sys//devices/pci0000:00/0000:00:1
Jul 18 20:10:02 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Found High speed device [091e:4b54] "0x091e, 0x4b54" at address 3944443
Jul 18 20:10:05 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Executed "" for onReset.091e.4b54
Jul 18 20:10:05 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Device 3944443 [091e:4b54] BOUND to connection 4
Jul 18 20:10:05 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[1461]: Executed "" for onReset.091e.4b54

Michael
.

OK try using the device, if its still not found then try this

Stop the virtualhere.service and edit the config.ini file and add the line

ClaimPorts=1

then save and start the virtualhere.service again

Now unplug-replug the usb device and try using via virtualhere. If that still fails i dont think it will work. Its something to do with the firmware inside the device would be my guess

drohm
Which section of virtualhere

Which section of virtualhere.service do I add that line? Under [Unit], [Service], or [Install]?

drohm
I placed that line in the

I placed that line in the [Service] section and the restarted the service. Tried again on the client but the GarminExpress and Windows 10 both don't see the device.

Server status:

● virtualhere.service - VirtualHere USB Sharing
Loaded: loaded (/etc/systemd/system/virtualhere.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2019-07-18 20:57:23 EDT; 7min ago
Main PID: 4324 (vhusbdx86_64hw)
Tasks: 39 (limit: 4915)
Memory: 5.7M
CGroup: /system.slice/virtualhere.service
└─4324 /usr/bin/vhusbdx86_64hw

Jul 18 21:00:17 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[4324]: Warning, could not open device product file /sys//devices/pci0000:00/0000:00:1
Jul 18 21:00:17 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[4324]: Found High speed device [091e:4b54] "0x091e, 0x4b54" at address 3944443
Jul 18 21:00:20 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[4324]: Executed "" for onReset.091e.4b54
Jul 18 21:00:20 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[4324]: Device 3944443 [091e:4b54] BOUND to connection 1
Jul 18 21:00:20 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[4324]: Executed "" for onReset.091e.4b54
Jul 18 21:00:44 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[4324]: Device 3944443 [091e:4b54] UNBOUND from connection 1
Jul 18 21:00:46 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[4324]: Executed "" for onReset.091e.4b54
Jul 18 21:00:46 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[4324]: Device 3944443 [091e:4b54] BOUND to connection 1
Jul 18 21:00:46 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[4324]: Executed "" for onReset.091e.4b54
Jul 18 21:02:56 ezyrhinox.hq.dougrohm.com vhusbdx86_64hw[4324]: Device 3944443 [091e:4b54] UNBOUND from connection 1

Michael
.

OK its not going to work unfortunately

drohm
Bummer, thanks for the help

Bummer, thanks for the help trying. Much appreciated.

Log in or register to post comments