OSX: Client can't install driver when trying to connect to a server->device

4 posts / 0 new
Last post
dmcnaugh
OSX: Client can't install driver when trying to connect to a server->device

Hi, I have the server (trial) set up on a WIn10 machine and have used EasyFind to get the Client to find the server. Every things working up to this point. I can see the server and its USB devices on the client.

When I try to connect to a device, the client starts to install a device driver under OSX and I get an error saying it can't.
I've followed the direction to reboot and try again, with the same result.
Here is the log from the client.

I'm really keen to get this working with the trial to perform some tests for using VirtualHere as a possible customer support vector.

2019-07-07 11:31:15 INFO :VirtualHere Client 4.7.9 starting (Compiled: Jun 21 2019 15:41:24)
2019-07-07 11:31:15 INFO :Client OS is macOS High Sierra Version 10.13.6 (Build 17G7024)
2019-07-07 11:31:15 INFO :Using config at /Users/dmcnaughton/Library/Preferences/vhui Preferences
2019-07-07 11:31:15 INFO :IPC available at /tmp/vhclient
2019-07-07 11:31:15 INFO :Auto-find using Bonjour - on
2019-07-07 11:31:15 INFO :Auto-find using Bonjour SSL - on
2019-07-07 11:31:21 INFO :No drivers installed, I am installing new ones...
2019-07-07 11:31:24 INFO :Using OSX 10.9+ driver
2019-07-07 11:31:44 INFO :Installed driver is now version
2019-07-07 11:31:44 ERROR :IOIteratorNext = 0. com_virtualhere_vhhcd is not correctly registered in the kernel, please reboot and try again
2019-07-07 11:32:57 INFO :Connection 1 closed (tx)
2019-07-07 11:32:57 INFO :Connection 1 remotely disconnected gracefully (rx)
2019-07-07 11:33:00 INFO :Server ping timeout, shutting down connection 1...
2019-07-07 11:33:01 INFO :assert:../src/common/event.cpp,1897,SearchDynamicEventTable,nNew != dynamicEvents.size(),

Michael
.
eraymond
Not sure if this is the same

Not sure if this is the same issue. Steps to reproduce are the same. There is no message in Security & Privacy to approve the kext (and I think I did that a while back?).

Very slow to perform the install of the driver (seems like it times out).

2019-10-06 21:22:11 INFO :VirtualHere Client 4.9.1 starting (Compiled: Sep 30 2019 15:43:37)
2019-10-06 21:22:11 INFO :Client OS is macOS Mojave Version 10.14.6 (Build 18G95)
2019-10-06 21:22:11 INFO :Using config at /Users/ericraymond/Library/Preferences/vhui Preferences
2019-10-06 21:22:11 INFO :IPC available at /tmp/vhclient
2019-10-06 21:22:11 INFO :Auto-find using Bonjour - on
2019-10-06 21:22:11 INFO :Auto-find using Bonjour SSL - on
2019-10-06 21:22:25 INFO :No drivers installed, I am installing new ones...
2019-10-06 21:22:27 INFO :Using OSX 10.9+ driver
2019-10-06 21:23:02 INFO :Installed driver is now version
2019-10-06 21:23:02 ERROR :IOIteratorNext = 0. com_virtualhere_vhhcd is not correctly registered in the kernel, please reboot and try again
2019-10-06 21:23:04 INFO :assert:../src/common/event.cpp,1897,SearchDynamicEventTable,nNew != dynamicEvents.size(),
2019-10-06 21:23:03 INFO :Server ping timeout, shutting down connection 1...
2019-10-06 21:23:04 INFO :Connection 1 receiving msg size didnt complete due to error 9, Bad file descriptor
2019-10-06 21:24:28 INFO :No drivers installed, I am installing new ones...
2019-10-06 21:24:30 INFO :Using OSX 10.9+ driver
2019-10-06 21:27:02 INFO :Installed driver is now version
2019-10-06 21:27:02 ERROR :IOIteratorNext = 0. com_virtualhere_vhhcd is not correctly registered in the kernel, please reboot and try again

eraymond
Needed to delete kext

I deleted the kext via sudo kextunload /Library/Extensions/vhhcd.kext and then rebooted. It works now.

Log in or register to post comments