Sharing issues of iPhone / iPad between OSX server and client

11 posts / 0 new
Last post
netmax
Sharing issues of iPhone / iPad between OSX server and client

Hi,

thank you for this great piece of software which basically works fine!

Unfortunately I have a serious issue connecting iPhones and iPads between an OSX server and client. The scenario:

I want to do automatic backups of my iDevices with iMazing. This function is only supported in the OSX version, so I've installed an OSX as a VM on one of my servers, and installed iMazing. The problem is that you need to pair the iDevice with the OSX ("Trust this computer") to get this working.

For a VM VirtualHere would be the perfect solution. It works like a charm from a Windows Client to a Windows VM, but the Windows version of iMazing does not support automatic backups.

I'm running the Client in the OSX VM of the server, I'm running the server as sudo on my MacBook Pro. The iDevice is plugged into my MacBook Pro and I'm seeing and then "using" the device in the OSX VM. The problem: On no iDevice connected to my physical MacBook this "using" process triggers the pairing process and the message "trust this computer" is not shown.

Even setting the iDevice as "Auto-use this device" in the OSX-VM and plugging the iDevice then into the MacBook does not work.

Where is the problem here, and what do I need to do to fix this? Any kind of custom parameters?

Thanks,
Marco

netmax
Log lines

That's the server log when connecting the iPad:

Jan 31 20:34:37 Marcos-MacBook-Pro vhusbdosx[4110] : Found High speed device [05ac:12ab] "Apple Inc., iPad" at address 338690048
Jan 31 20:34:37 Marcos-MacBook-Pro vhusbdosx[4110] : Device 338690048 [05ac:12ab] BOUND to connection 38
Jan 31 20:34:37 Marcos-MacBook-Pro vhusbdosx[4110] : reenumerateInterfaces: USBInterfaceOpen error kIOReturnExclusiveAccess (exclusive access) at IOService:/IOResources/AppleUSBHostResources/AppleUSBLegacyRoot/AppleUSBXHCI@14000000/iPad@14300000
Jan 31 20:34:42 Marcos-MacBook-Pro vhusbdosx[4110] : reenumerateInterfaces: USBInterfaceOpen error kIOReturnExclusiveAccess (exclusive access) at IOService:/IOResources/AppleUSBHostResources/AppleUSBLegacyRoot/AppleUSBXHCI@14000000/iPad@14300000

Michael
.

I just ran a test of my iPad like this

1. I have an ipad running iOS 12.1.3
2. Plug it into my macbook air running OSX 10.14.2 and virtualhere server for osx 3.8.1
3. Try to use iPad via virtualhere inside an OSX 10.14.2 vm running on another machine
4. Server pops up dialog saying sudo is need. Server restarts with sudo
5. In client VM, click Use on the the iPad again->Nothing happens, ipad disconnects itself and comes back a few seconds later
6. Click Use on the iPad again-> Now itunes pops up and says i need to authorize on the iPad.
7. I click ok and then authorize on the ipad
8. iTunes continues and i can use the remotely connected iPad just as if it was local

So it works ok. However i notice step 5 the ipad disappears and the returns a few seconds later. Does yours do this?

netmax
Hi Michael,

Hi Michael,

mine does not disappear. It just says "In use by you" in the client VM but nothing happens. No Popup on the iPad to trust the computer, the iPad does not appear in iTunes in the Client VM.

OSX is 10.14.3 on all sides, the USBServer was downloaded as 3.8.1, but Settings -> About shows version 3.8.0 (maybe a bug in "About").
Client is 4.6.5.

So, what's different? What USB controllers did you add to your ESXi OSX VM? USB 2.0, 3.0 or both? Anything else I might have missed?

netmax
Addon: I've tried the server

Addon: I've tried the server on my MacBook Pro 13" as well as on the MacBook Air from my wife. The behavior is the same.

Michael
.

You must have some software holding control of the iDevice.

The "ExclusiveAccess" error in the log is a clue. On my macbook i dont have anything special installed. So the iDevice is not held by anything and passthrough via virtualhere works fine and i dont get that error.

Perhaps you have iMazing on the server and that is holding control of the iPad so it cannot be taken by virtualhere and redirected? You might want to temporary uninstall iMazing from the server, reboot the server then try via virtualhere again.

netmax
Yes, I have iMazing on the

Yes, I have iMazing on the MacBook ... but I've not started it and iMazing Mini does also not run on the MacBooks. Isn't simply also iTunes using an iDevice once it's plugged into a Mac?

I tried to use some other devices running the server which definitely do anything with the iDevice. A Windows PC, a Linux PC and my QNAP. But that looks even worse! It appears as if any other platforms except my MacBook simply do not work with an iDevice and even worse: My iDevices often do restarts after I've tried to use them with any other server platform.

I'll however uninstall iMazing for a test and report back.

netmax
Another thing: The error

Another thing: The error about "exclusiveAccess" does not happen every time. But I often see this message, what does this mean:

Feb 4 12:57:09 Marcos-MBP vhusbdosx[1112] : DEPRECATED USE in libdispatch client: dispatch source activated with no event handler set; set a breakpoint on _dispatch_bug_deprecated to debug

Michael
.

You must use either windows Server->windows client or osx server->osx client. You cannot mix the server and client os with the iDevice it wont work

ZooL
any updates?

I also cannot get my iphone 8 with ios 12 to work.
any updates on the issue?

Michael
.

no

Log in or register to post comments