Status of iLok support on Sierra?

17 posts / 0 new
Last post
cjonesnyc
Status of iLok support on Sierra?

I'm currently using:
OSX: 10.12.2
VH Client: 3.8.9
VH Server 3.1.9 using Synology

Using Virtual Here and an iLok worked for me the first time I set it up but after that, any program that needs to check the iLok freezes up. Disconnecting and reconnecting the iLok works inconsistently and isn't really an option for me anyway. I saw this was happening for other people about a year ago but it doesn't look like there's an actual fix for this yet. Is iLok still supported or expected to work with VirtualHere at some point?

Michael
It should work ok with sierra

It should work ok with sierra now? Im surprised about this. Are you talking about which software? ProTools?

Does it even freeze even when using the ilok license manager?

Your network is stable? I.e LAN or is it a WAN?

cjonesnyc
LAN,

LAN,
It's been freezing for me with the iLok License Manager, Audio Ease Altiverb plugin and. Synchro Arts' Revoice Pro. With Revoice I can usually just disconnect and reconnect with the client and get it to start but that doesn't work for the license manager and rarely works with Altiverb, plus it seems to check the license periodically.

I was also able to get it to work temporarily by turning the Synology unit off and on.

Michael
.

I connected my iLok to my synology ds213j running the lastest "DSM-6.0.2-8451 Update 4" and used it via virtualhere running in OSX 10.12.3 beta (16D17A).

I tried pressing the "synchronize" item on the iLok License Manager to make the iLok busy for a while and i did not see any issues. The synology and virtualhere client machine are connected over a ethernet cable. I left the ilok license manager running for 2hrs and every 10mins or so i would press the synchronize ilok button. I also renamed the ilok a few times via the license manager to generate some more traffic.

So my best guess for you issue is as follows:

1. It might be some fix apple made in 10.12.3 (but i doubt it)
2. The network connection is dropping and reconnecting but packets are lost
3. There is a bug in the synology kernel on your particular synology
4. There is a bug in the virtualhere osx driver

Im not sure which of these is your issue but the end result is that i cannot change the osx driver in virtualhere because apple has temporarily removed support but side loaded support back into 10.12.2 for virtualhere (due to so many manufacturer complains i think) Once apple officially supports software like virtualhere there might be more scope to debug and create a fix for your situation.

Alternative you could try getting the latest osx beta if you are a apple developer or make sure you have the latest synology dsm updates.

cjonesnyc
.

looks like my plugins are working with 10.12.3. ilok license manager still hangs though.

Michael
.

Can you update to virtualhere server 3.2.2 and see if that fixes the ilok manager hang...

cjonesnyc
.

Still hangs with 3.2.2 .

Fredb
not working with server 3.4.2 and sierra 10.12.6

not working with server 3.4.2 and sierra 10.12.6

rcschletty
iLok 2nd Gen, server 3.4.6, Mac client Sierra 10.12.6

Server 3.4.6, Mac client 4.3.2 on Sierra 10.12.6. I am getting this error when trying to use an iLok 2nd Generation:

"iLok Sharing Error. An iLok cannot be shared across multiple operating systems or computers. Disconnect and reconnect your iLok when switching to another OS/Computer."

My iLok 1 plugged into the same Synology box does not give the error.

After throwing up the error, VirtualHere says "in use by you" but music libraries will not load, and iLok License Manager 3.1.7.899 has trouble communicating with the iLok 2nd Gen.

Multiple reboots of Synology DS 1513+ (DSM 6.1.3-15152 Update 8) do not solve the issue. My iLok 1 plugged into the same Synology box does not give the error.

Physically unplugging and replugging the iLok 2nd Generation dongle fixes the problem. But this is quite impractical as a "fix" because I am sometimes in another part of the building (same network) or at a remote location wanting to use the iLok 2nd Gen on my MacBook Pro. Note that the exact same error occurs on both my Mac Pro and my MacBook Pro – both running Sierra 10.12.6.

I need a way to have the Synology VirtualHere server COMPLETELY release the iLok 2nd Gen dongle when switching between my two Mac OS X workstations.

Michael
.

VirtualHere has the in-built ability to automatically power cycle the port when you use an iLok.

However most manufacturers dont bother wiring their usb hubs correctly. Including some synology NAS's unfortunately.

The only way to power cycle correctly that i know of is to use a raspberry pi as the virtualhere server.

OR, If you want to take a chance on a hub that might powercycle correctly you could try one of these. https://github.com/mvp/uhubctl

I have found the amazon hub they list is no longer supporting per port power cycle so i recommend getting a raspberry pi .

rcschletty
iLok 2nd Gen, server 3.4.6, Mac client Sierra 10.12.6

Michael, the point I should have made is that user switching (and presumably power cycling) did work correctly with Mac OS X Yosemite. I am only recently encountering this issue with Sierra. That is why I posted here in this "iLok support on Sierra" thread. Also, you should take note that I mentioned my iLok 1 is doing user switching flawlessly. Really hard for me to point a finger at Mac OS, iLok 2nd Gen or my Synology USB ports.

Michael
.

So the 2nd gen ilok via yosemite was switching ok, but under seirra it's not?

rcschletty
iLok 2nd Gen switching

I'm pretty sure both iLok 1 and 2nd Gen were switching with Yosemite. I can test with a third workstation soon that is running El Capitan. Idon't have any Macs running Yosemite now.

Michael
.

VirtualHere wont work on elcaptian at all. Apple pulled support for this (but reluctantly added it back in in 10.12.1)

At the moment, what i think is happening is this: I think that the ilok 1 does not require power cycling to move between machines. The ilok 2 definitely does require power cycling. I think that your synology is not actually power cycling the port. So you would only notice this issue when using the ilok2. Physically replugging the ilok 2 is essentially just the same as if you had a per-port power cycle supported server. And i think you would find that with yosemite the ilok2 did require replugging...

rcschletty
iLok switching works between El Capitan 10.11.6 and Sierra 10.12

With my Synology DS 1513+ running the latest DSM version and the latest VH server version, iLok 2nd Gen switching WORKS between El Capitan 10.11.6 (on my 2007 iMac) and Sierra 10.12.6 (on my early 2009 Mac Pro). I just tested it. No "iLok Sharing Error. "

What does NOT work is user switching on my MacBook Pro (late 2016) running Sierra 10.12.6. What I will do is attempt to uninstall VirtualHere client 4.3.2 completely (app and prefs) from my my MacBook Pro and reinstall. I may also uninstall iLok License Manager.app. Some have pointed a finger at this as a possible reason for the "iLok Sharing Error. " iLok License Manager is not currently installed on my old 2007 iMac. It is installed on my Mac Pro (early 2009).

FYI, I tried the iMac 2007 VH connection with both ethernet and wifi, thinking that may be a factor. User switching works with both connections.

rcschletty
The culprit is iLok License Manager!

I have determined that iLok License Manager cannot be installed on two Macs on the same network – it prevents user switching. As soon as I uninstalled iLok License Manager 3.1.7, user switching started to work on my MacBook Pro.

Interestingly, a new version 4.0 of iLok License Manager appeared this evening (11/2/2017). Among its improvements, it includes firmware updates for iLok 2nd and 3rd Gen. I did install version 4.0 but that did not prevent the "iLok Sharing Error" which appeared a soon as installation of iLok License Manager was complete. I had noticed this the other day with a recent iLok License Manager update – it should have been my clue!

There was a hint of this solution at this thread which I had read yesterday: https://www.gearslutz.com/board/product-alerts-older-than-2-months/99897...

Michael
.

OK great! that info will be useful for others im sure... thanks for letting me know

Log in or register to post comments