USB Stick not recognized by plugin-alliance license check

12 posts / 0 new
Last post
Damageplan
USB Stick not recognized by plugin-alliance license check

Hi Michael,

I've encountered a strange problem I cannot solve without your help.
I'm using a USB stick for my Waves licenses and it's working perefctly fine.
No I wanted to do the same with my plugin-alliance licenses on the same USB stick since they also support this.
But the plugins cannot find the license on this stick when mounted via virtualhere.
When the USB stick is directly connected to a Mac or PC the licenses getting recognized.

I searched a bit on their website and stumpled upon a FAQ entry that claims that only USB sticks with serial numbers are supported.
Can this be the problem?

Thanks for your help
Matthias

Damageplan
To be more precise:

To be more precise:
It does not work with macOS 10.13.5.
If tried it now with Windows 10 v1803 and it works.
Michael, can you help?
Both server and clients are on the latest version.

Thanks
Matthias

Michael
.

If it doesnt work on osx there is no much that can be done at the moment until apple puts back in support. No ETA when this will be done

Damageplan
Out of interest. What is it

Out of interest. What is it that Apple has to bring back?
Thanks!

Michael
.

Support for "3rd Party USB Host Controller"s

Damageplan
So there's nothing you can do

So there's nothing you can do about?
The stick is mounted correctly, I can access it via finder.
But the plugin license check does not recognize it :-(

thrakotool
+1 on this: my iLok has been

+1 on this: my iLok has been working just fine with VirtualHere up until my recent upgrade to El Capitan.
Now VirtualHere sees the iLok, and even the iLok Manager sees the dongle and licensed on it, but as soon as I try to use any license within my software - it doesn't see/recognize the key.
Same story with my Steinberg eLicenser.
Can anyone confirm this is indeed a "3rd Party USB Host Controller" issue? At least that's something to base further research on...

Michael
.ok

Yes all was good untul 10.11 when apple completely broke support. As you can find on various postings by searching on this site. From my understanding apple is really more interested in marketing and their software quality has massively deteriated the last few years. Microsoft has been almost the complete opposite

thrakotool
Thank you Michael, I really

Thank you Michael, I really appreciate you confirming this.
I've already tried to replace the USBEHCI and USBXHCI kexts with the older Yosemite ones, and while they do work in El Capitan, that didn't fix the issue... I wonder which parts of the USB library affect 3rd part host controllers the most.

Damageplan
No problems here with iLok or

No problems here with iLok or Steinberg eLicenser here on my end.
Works as expected.
Btw. I‘m on macOS 10.13.6 and 10.14 for testing.

thrakotool
Thanks Damageplan, that's

Thanks Damageplan, that's reassuring.
I've upgraded both the server and the client machine from 10.11 to 10.12.6, and apparently 10.12 doesn't help much...
Just to confirm: is it normal to have the driver in /Library/Extensions instead of /System/Library/Extensions? And to have its permission set to System=RW, Everyone=No access?

Michael
In osx 10.12 the drivers for

In osx 10.12 the drivers for 3rd party software needs to go in libary/extensions now. @thrakotool I think you should try 10.13 if you can

Log in or register to post comments