Windows Server Version 3.0.6 error

12 posts / 0 new
Last post
trickyb_uk
Windows Server Version 3.0.6 error

Hello,

I recently updated our windows server (win 7 x64) to the latest release and none of the dongles will now connect...

the log from three attempts:

2016-09-27 07:17:12 ERROR :DiInstallDevice failed, The name is already in use as either a service name or a service display name. (0x00000436)
2016-09-27 07:17:12 ERROR :Error binding device 21 [0529:0001] to connection 14, BIND_ERROR
2016-09-27 07:17:15 ERROR :DiInstallDevice failed, The name is already in use as either a service name or a service display name. (0x00000436)
2016-09-27 07:17:15 ERROR :Error binding device 1 [064f:03e9] to connection 14, BIND_ERROR
2016-09-27 07:17:19 ERROR :DiInstallDevice failed, The name is already in use as either a service name or a service display name. (0x00000436)
2016-09-27 07:17:19 ERROR :Error binding device 23 [0529:0001] to connection 14, BIND_ERROR

All the previous versions have been fine. Any ideas?

Thanks

Richard

Michael
Ok, can you do this

Ok, can you do this

vhusbdwin64.exe -u
then reboot your windows computer
then run the server again.

trickyb_uk
No joy...

Michael, carried out that procedure twice. no change:

2016-09-27 08:17:10 INFO :Installing driver for class USB {00000000-0000-0000-0000-000000000000}
2016-09-27 08:17:24 INFO :OK driver installed try again...
2016-09-27 08:17:26 ERROR :DiInstallDevice failed, The name is already in use as either a service name or a service display name. (0x00000436)
2016-09-27 08:17:26 ERROR :Error binding device 23 [0529:0001] to connection 4, BIND_ERROR
2016-09-27 08:17:32 INFO :Installing driver for class HIDClass {745A17A0-74D3-11D0-B6FE-00A0C90F57DA}
2016-09-27 08:17:51 INFO :OK driver installed try again...
2016-09-27 08:17:54 ERROR :DiInstallDevice failed, The name is already in use as either a service name or a service display name. (0x00000436)
2016-09-27 08:17:54 ERROR :Error binding device 24 [096e:0006] to connection 4, BIND_ERROR
2016-09-27 08:18:01 ERROR :DiInstallDevice failed, The name is already in use as either a service name or a service display name. (0x00000436)
2016-09-27 08:18:01 ERROR :Error binding device 25 [064f:03e9] to connection 4, BIND_ERROR

Just to double check - could you send me a link to the previous version?

Richard

Michael
Unfortunately i dont have the

Unfortunately i dont have the exact binary, so i had to recompile with 3.0.5 source code. Could you try this version https://www.virtualhere.com/vhusbdwin64.exe

trickyb_uk
Very odd

Michael - same result with v3.0.5

I ran 'vhusbdwin64.exe -u' and rebooted prior to running the server, just to be sure. Same outcome.

FYI, we have Linux server (currently at v3.0.4 due to constant use) running along side. This Windows server holds 'emergency use' dongles - which are identical to those working with Linux.

I also tried removing a dongle (device 20 in the log) and reconnecting - local drivers installed fine.

Anything else I can try?

latest log:

2016-09-27 08:49:50 INFO :>>> Starting VirtualHere USB Server v3.0.5 (Built: Sep 27 2016, 17:26:21)<<<
2016-09-27 08:49:50 INFO :Using configuration config.ini
2016-09-27 08:49:50 INFO :Server licensed to=fdac55de-f2a1-4b66-8ee1-49dfd83d33b2 max_devices=unlimited
2016-09-27 08:49:51 INFO :TCPServer starting...
2016-09-27 08:49:51 INFO :Listening on all network interfaces at port 7575 (IPv6 dual-stack)
2016-09-27 08:49:51 INFO :Registration called
2016-09-27 08:49:51 INFO :Found High speed device [090c:1000] "USB, Flash Disk" at address 20
2016-09-27 08:49:51 INFO :Found Low speed device [0529:0001] "AKS, HASP HL 3.25" at address 21
2016-09-27 08:49:51 INFO :Found Full speed device [064f:03e9] "WIBU-SYSTEMS AG, CodeMeter-Stick " at address 1
2016-09-27 08:49:51 INFO :Found Full speed device [0a89:000c] "Aktiv Co., Stealth III Sign" at address 22
2016-09-27 08:49:51 INFO :Found Low speed device [0529:0001] "AKS, HASP HL 3.25" at address 23
2016-09-27 08:49:51 INFO :Found Low speed device [096e:0006] "OEM, HID Dongle" at address 24
2016-09-27 08:49:51 INFO :Found Full speed device [064f:03e9] "WIBU-SYSTEMS AG, CodeMeter-Stick " at address 25
2016-09-27 08:50:03 INFO :fe80::5d2c:128:1372:aca8 connected
2016-09-27 08:50:04 INFO :fe80::fdd3:fe1b:a4b3:f1d1 connected
2016-09-27 08:50:05 INFO :fe80::7491:91db:ac26:e586 connected
2016-09-27 08:50:06 INFO :fe80::3c09:7e47:3da4:d5be connected
2016-09-27 08:50:07 INFO :fe80::ce7:48f8:58ca:6c66 connected
2016-09-27 08:50:10 INFO :fe80::2c34:b804:bc1d:f3d7 connected
2016-09-27 08:50:15 INFO :fe80::5828:6690:8d18:9588 connected
2016-09-27 08:50:15 INFO :fe80::cc63:f0b2:d9e9:6197 connected
2016-09-27 08:50:15 INFO :fe80::31a7:3aa1:9155:a520 connected
2016-09-27 08:50:18 INFO :fe80::7d1b:5a57:b5a6:7753 connected
2016-09-27 08:50:19 INFO :fe80::c959:64f9:ae1b:dee7 connected
2016-09-27 08:50:20 INFO :fe80::bdbe:c5f6:dfb0:c5d connected
2016-09-27 08:50:27 INFO :fe80::c4ec:69a7:8c0c:a754 connected
2016-09-27 08:50:27 INFO :fe80::1488:fb93:298a:1a33 connected
2016-09-27 08:50:30 INFO :fe80::c058:b68c:22bb:f040 connected
2016-09-27 08:51:04 INFO :Installing driver for class USB {36FC9E60-C465-11CF-8056-444553540000}
2016-09-27 08:51:22 INFO :OK driver installed try again...
2016-09-27 08:51:22 ERROR :DiInstallDevice failed, The name is already in use as either a service name or a service display name. (0x00000436)
2016-09-27 08:51:22 ERROR :Error binding device 25 [064f:03e9] to connection 11, BIND_ERROR
2016-09-27 08:51:41 ERROR :DiInstallDevice failed, The name is already in use as either a service name or a service display name. (0x00000436)
2016-09-27 08:51:41 ERROR :Error binding device 20 [090c:1000] to connection 11, BIND_ERROR
2016-09-27 08:52:00 INFO :Unmanaging device 20 [090c:1000]
2016-09-27 08:52:05 INFO :Found High speed device [090c:1000] "USB, Flash Disk" at address 20
2016-09-27 08:52:16 ERROR :DiInstallDevice failed, The name is already in use as either a service name or a service display name. (0x00000436)
2016-09-27 08:52:16 ERROR :Error binding device 20 [090c:1000] to connection 11, BIND_ERROR

Thanks

Richard

Michael
OK, try this

OK, try this

1. vhusbdwin64.exe -u
2. start regedt32
3. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
4. Look for vhsd_* entries and delete them all
5. vhusbdwin64.exe
6. Try using a device via virtualhere

trickyb_uk
Half-way there...

Michael,

Some additional strange behaviour for your perusal.

Followed the process above. The 'vhsd' key and it's contents was deleted. vhusbdwin64.exe -u and reboot again.

This time, Device 22 and 24 connected, the other 5 less so. Don't think I've ever seen 'getPortStatusImpl!' before in the log:

2016-09-27 09:32:07 INFO :>>> Starting VirtualHere USB Server v3.0.5 (Built: Sep 27 2016, 17:26:21)<<<
2016-09-27 09:32:07 INFO :Using configuration config.ini
2016-09-27 09:32:07 INFO :Server licensed to=fdac55de-f2a1-4b66-8ee1-49dfd83d33b2 max_devices=unlimited
2016-09-27 09:32:08 INFO :TCPServer starting...
2016-09-27 09:32:08 INFO :Listening on all network interfaces at port 7575 (IPv6 dual-stack)
2016-09-27 09:32:08 INFO :Registration called
2016-09-27 09:32:08 INFO :Found High speed device [090c:1000] "USB, Flash Disk" at address 20
2016-09-27 09:32:08 INFO :Found Low speed device [0529:0001] "AKS, HASP HL 3.25" at address 21
2016-09-27 09:32:08 INFO :Found Full speed device [064f:03e9] "WIBU-SYSTEMS AG, CodeMeter-Stick " at address 1
2016-09-27 09:32:08 INFO :Found Full speed device [0a89:000c] "Aktiv Co., Stealth III Sign" at address 22
2016-09-27 09:32:08 INFO :Found Low speed device [0529:0001] "AKS, HASP HL 3.25" at address 23
2016-09-27 09:32:08 INFO :Found Low speed device [096e:0006] "OEM, HID Dongle" at address 24
2016-09-27 09:32:08 INFO :Found Full speed device [064f:03e9] "WIBU-SYSTEMS AG, CodeMeter-Stick " at address 25
2016-09-27 09:32:24 INFO :fe80::31a7:3aa1:9155:a520 connected
2016-09-27 09:32:24 INFO :fe80::c058:b68c:22bb:f040 connected
2016-09-27 09:32:25 INFO :fe80::c959:64f9:ae1b:dee7 connected
2016-09-27 09:32:27 INFO :fe80::1488:fb93:298a:1a33 connected
2016-09-27 09:32:28 INFO :fe80::cc63:f0b2:d9e9:6197 connected
2016-09-27 09:32:28 INFO :fe80::c4ec:69a7:8c0c:a754 connected
2016-09-27 09:32:31 INFO :fe80::fdd3:fe1b:a4b3:f1d1 connected
2016-09-27 09:32:36 INFO :fe80::3c09:7e47:3da4:d5be connected
2016-09-27 09:32:37 INFO :fe80::2c34:b804:bc1d:f3d7 connected
2016-09-27 09:32:40 INFO :fe80::ce7:48f8:58ca:6c66 connected
2016-09-27 09:32:44 INFO :fe80::7d1b:5a57:b5a6:7753 connected
2016-09-27 09:32:45 INFO :fe80::ec86:125a:cc0:dfa6 connected
2016-09-27 09:32:45 INFO :fe80::5d2c:128:1372:aca8 connected
2016-09-27 09:32:45 INFO :fe80::7491:91db:ac26:e586 connected
2016-09-27 09:32:47 INFO :fe80::5828:6690:8d18:9588 connected
2016-09-27 09:33:20 INFO :fe80::bdbe:c5f6:dfb0:c5d connected
2016-09-27 09:33:30 INFO :Installing driver for class HIDClass {745A17A0-74D3-11D0-B6FE-00A0C90F57DA}
2016-09-27 09:33:45 INFO :OK driver installed try again...
2016-09-27 09:33:57 INFO :Device 24 [096e:0006] BOUND to connection 3
2016-09-27 09:34:03 INFO :Installing driver for class USB {00000000-0000-0000-0000-000000000000}
2016-09-27 09:34:12 INFO :OK driver installed try again...
2016-09-27 09:34:16 ERROR :DiInstallDevice failed, The name is already in use as either a service name or a service display name. (0x00000436)
2016-09-27 09:34:16 ERROR :Error binding device 21 [0529:0001] to connection 3, BIND_ERROR
2016-09-27 09:34:28 ERROR :DiInstallDevice failed, The name is already in use as either a service name or a service display name. (0x00000436)
2016-09-27 09:34:28 ERROR :Error binding device 1 [064f:03e9] to connection 3, BIND_ERROR
2016-09-27 09:34:32 ERROR :DiInstallDevice failed, The name is already in use as either a service name or a service display name. (0x00000436)
2016-09-27 09:34:32 ERROR :Error binding device 20 [090c:1000] to connection 3, BIND_ERROR
2016-09-27 09:34:37 INFO :Device 22 [0a89:000c] BOUND to connection 3
2016-09-27 09:34:41 ERROR :DiInstallDevice failed, The name is already in use as either a service name or a service display name. (0x00000436)
2016-09-27 09:34:41 ERROR :Error binding device 25 [064f:03e9] to connection 3, BIND_ERROR
2016-09-27 09:34:49 ERROR :DiInstallDevice failed, The name is already in use as either a service name or a service display name. (0x00000436)
2016-09-27 09:34:49 ERROR :Error binding device 23 [0529:0001] to connection 3, BIND_ERROR
2016-09-27 09:35:30 INFO :Device 24 [096e:0006] UNBOUND from connection 3
2016-09-27 09:35:38 INFO :Device 24 [096e:0006] BOUND to connection 3
2016-09-27 09:35:42 INFO :Device 22 [0a89:000c] UNBOUND from connection 3
2016-09-27 09:35:42 INFO :getPortStatusImpl!
2016-09-27 09:35:51 INFO :Device 22 [0a89:000c] BOUND to connection 3
2016-09-27 09:38:41 INFO :Device 22 [0a89:000c] UNBOUND from connection 3
2016-09-27 09:38:41 INFO :getPortStatusImpl!
2016-09-27 09:38:43 INFO :Device 24 [096e:0006] UNBOUND from connection 3

Richard

Michael
That is weird, there was

That is weird, there was almost no changes between 3.0.5 and 3.0.6 just a small change to some TCP networking code.

Could you roll back your windows 7 machine if possible, to the previous "Restore Point" http://acer.custhelp.com/app/answers/detail/a_id/13060/~/how-do-i-use-sy...

Im wondering if there is some registry corruption on that machine?

trickyb_uk
Working - but not completely resolved...

Michael, some good news. The dongles attached to the windows server can now be bound.

However, I initially restored back a week or so - before updating to 3.0.6. No change.

I then restored back a month - late August. That had kept a copy of version 3.0.2 - which worked fine.

I then updated to 3.0.6 - and we were back with 'unable to use...'

I restored again, and am now running 3.0.2 again.

Very strange. As I had previously installed 3.0.3 through 3.0.5 as you released them, there were never any problems...

Here's the log for the change from 3.0.2 to 3.0.6 - in case anything new can help you:

2016-09-27 10:32:57 INFO :Device 21 [0529:0001] BOUND to connection 15
2016-09-27 10:33:06 INFO :Device 1 [064f:03e9] BOUND to connection 15
2016-09-27 10:34:42 INFO :>>> Starting VirtualHere USB Server v3.0.2 (Built: Aug 17 2016, 17:35:51)<<<
2016-09-27 10:34:42 INFO :Using configuration config.ini
2016-09-27 10:34:42 INFO :Server licensed to=fdac55de-f2a1-4b66-8ee1-49dfd83d33b2 max_devices=unlimited
2016-09-27 10:34:42 INFO :TCPServer starting...
2016-09-27 10:34:42 INFO :Listening on all network interfaces at port 7575 (IPv6 dual-stack)
2016-09-27 10:34:42 INFO :Registration called
2016-09-27 10:34:43 INFO :Found Low speed device [0529:0001] "AKS, HASP HL 3.25" at address 21
2016-09-27 10:34:43 INFO :Found Full speed device [064f:03e9] "WIBU-SYSTEMS AG, CodeMeter-Stick " at address 1
2016-09-27 10:34:43 INFO :Found Full speed device [0a89:000c] "Aktiv Co., Stealth III Sign" at address 22
2016-09-27 10:34:43 INFO :Found Low speed device [0529:0001] "AKS, HASP HL 3.25" at address 23
2016-09-27 10:34:43 INFO :Found Low speed device [096e:0006] "OEM, HID Dongle" at address 24
2016-09-27 10:34:43 INFO :Found Full speed device [064f:03e9] "WIBU-SYSTEMS AG, CodeMeter-Stick " at address 25
2016-09-27 10:34:43 INFO :fe80::2c34:b804:bc1d:f3d7 connected
2016-09-27 10:34:57 INFO :fe80::3c09:7e47:3da4:d5be connected
2016-09-27 10:34:57 INFO :fe80::1488:fb93:298a:1a33 connected
2016-09-27 10:34:58 INFO :fe80::fdd3:fe1b:a4b3:f1d1 connected
2016-09-27 10:34:58 INFO :fe80::c4ec:69a7:8c0c:a754 connected
2016-09-27 10:34:58 INFO :fe80::c058:b68c:22bb:f040 connected
2016-09-27 10:34:58 INFO :fe80::7491:91db:ac26:e586 connected
2016-09-27 10:35:05 INFO :fe80::31a7:3aa1:9155:a520 connected
2016-09-27 10:35:12 INFO :fe80::c959:64f9:ae1b:dee7 connected
2016-09-27 10:35:12 INFO :fe80::cc63:f0b2:d9e9:6197 connected
2016-09-27 10:35:14 INFO :fe80::5d2c:128:1372:aca8 connected
2016-09-27 10:35:15 INFO :fe80::ec86:125a:cc0:dfa6 connected
2016-09-27 10:35:19 INFO :fe80::7d1b:5a57:b5a6:7753 connected
2016-09-27 10:35:23 INFO :fe80::bdbe:c5f6:dfb0:c5d connected
2016-09-27 10:35:24 INFO :Device 21 [0529:0001] BOUND to connection 9
2016-09-27 10:35:28 ERROR :DiInstallDevice failed, (0xe0000203)
2016-09-27 10:35:28 INFO :Device 21 [0529:0001] UNBOUND from connection 9
2016-09-27 10:35:35 INFO :Device 1 [064f:03e9] BOUND to connection 9
2016-09-27 10:35:50 INFO :fe80::5828:6690:8d18:9588 connected
2016-09-27 10:36:09 ERROR :Reboot required! to finish installing USB\VID_064F&PID_03E9\0001189127
2016-09-27 10:36:09 INFO :Device 1 [064f:03e9] UNBOUND from connection 9
2016-09-27 10:36:09 INFO :Connection 9 remotely disconnected gracefully (rx msg size)
2016-09-27 10:36:20 INFO :Connection 9 successfully removed (reason:timeout)
2016-09-27 10:36:38 INFO :Device 21 [0529:0001] BOUND to connection 15
2016-09-27 10:37:19 ERROR :DiInstallDevice failed, (0xe0000203)
2016-09-27 10:37:19 INFO :Device 21 [0529:0001] UNBOUND from connection 15
2016-09-27 10:37:22 INFO :Device 22 [0a89:000c] BOUND to connection 15
2016-09-27 10:37:27 INFO :Device 22 [0a89:000c] UNBOUND from connection 15
2016-09-27 10:37:27 INFO :getPortStatusImpl!
2016-09-27 10:37:29 INFO :Device 25 [064f:03e9] BOUND to connection 15
2016-09-27 10:37:35 INFO :Device 25 [064f:03e9] UNBOUND from connection 15
2016-09-27 10:37:39 INFO :Device 24 [096e:0006] BOUND to connection 15
2016-09-27 10:39:13 INFO :Device 24 [096e:0006] UNBOUND from connection 15
2016-09-27 10:39:18 INFO :Device 23 [0529:0001] BOUND to connection 15
2016-09-27 10:39:22 ERROR :DiInstallDevice failed, (0xe0000203)
2016-09-27 10:39:22 INFO :Device 23 [0529:0001] UNBOUND from connection 15
2016-09-27 10:39:24 INFO :Device 1 [064f:03e9] BOUND to connection 15
2016-09-27 10:39:30 INFO :Device 1 [064f:03e9] UNBOUND from connection 15
2016-09-27 10:44:08 INFO :>>> Starting VirtualHere USB Server v3.0.6 (Built: Sep 24 2016, 09:55:46)<<<
2016-09-27 10:44:08 INFO :Using configuration config.ini
2016-09-27 10:44:08 INFO :Server licensed to=fdac55de-f2a1-4b66-8ee1-49dfd83d33b2 max_devices=unlimited
2016-09-27 10:44:08 INFO :running uninstaller C:\PROGRA~1\DIFX\1B2DAACF6AAD5997\dpinsts.exe /u C:\Windows\System32\DriverStore\FileRepository\vhsdn.inf_amd64_neutral_136625708d933958\vhsdn.inf /q
2016-09-27 10:44:08 INFO :running uninstaller C:\PROGRA~1\DIFX\1B2DAACF6AAD5997\dpinsts.exe /u C:\Windows\System32\DriverStore\FileRepository\vhsd.inf_amd64_neutral_22e32e548e817be9\vhsd.inf /q
2016-09-27 10:44:09 INFO :running uninstaller C:\PROGRA~1\DIFX\1B2DAACF6AAD5997\dpinsts.exe /u C:\Windows\System32\DriverStore\FileRepository\vhsdw.inf_amd64_neutral_3ded2edfb10c3ee1\vhsdw.inf /q
2016-09-27 10:44:09 INFO :running uninstaller C:\PROGRA~1\DIFX\1B2DAACF6AAD5997\dpinsts.exe /u C:\Windows\System32\DriverStore\FileRepository\vhsdp.inf_amd64_neutral_71fdd2c7116e244b\vhsdp.inf /q
2016-09-27 10:44:09 INFO :running uninstaller C:\PROGRA~1\DIFX\1B2DAACF6AAD5997\dpinsts.exe /u C:\Windows\System32\DriverStore\FileRepository\vhsds.inf_amd64_neutral_28313cd3e89fb141\vhsds.inf /q
2016-09-27 10:44:10 INFO :running uninstaller C:\PROGRA~1\DIFX\1B2DAACF6AAD5997\dpinsts.exe /u C:\Windows\System32\DriverStore\FileRepository\vhsdb.inf_amd64_neutral_c08dea850bdbb0c5\vhsdb.inf /q
2016-09-27 10:44:10 INFO :running uninstaller C:\PROGRA~1\DIFX\1B2DAACF6AAD5997\dpinsts.exe /u C:\Windows\System32\DriverStore\FileRepository\vhsdh.inf_amd64_neutral_9e0b10f233d1de47\vhsdh.inf /q
2016-09-27 10:44:10 INFO :running uninstaller C:\PROGRA~1\DIFX\1B2DAACF6AAD5997\dpinsts.exe /u C:\Windows\System32\DriverStore\FileRepository\vhsdi.inf_amd64_neutral_2a4f4f498489e1be\vhsdi.inf /q
2016-09-27 10:44:11 INFO :TCPServer starting...
2016-09-27 10:44:11 INFO :Listening on all network interfaces at port 7575 (IPv6 dual-stack)
2016-09-27 10:44:11 INFO :Registration called
2016-09-27 10:44:11 INFO :Found Low speed device [0529:0001] "AKS, HASP HL 3.25" at address 21
2016-09-27 10:44:11 INFO :Found Full speed device [064f:03e9] "WIBU-SYSTEMS AG, CodeMeter-Stick " at address 1
2016-09-27 10:44:11 INFO :Found Full speed device [0a89:000c] "Aktiv Co., Stealth III Sign" at address 22
2016-09-27 10:44:11 INFO :Found Low speed device [0529:0001] "AKS, HASP HL 3.25" at address 23
2016-09-27 10:44:11 INFO :Found Low speed device [096e:0006] "OEM, HID Dongle" at address 24
2016-09-27 10:44:11 INFO :Found Full speed device [064f:03e9] "WIBU-SYSTEMS AG, CodeMeter-Stick " at address 25
2016-09-27 10:44:11 INFO :Found High speed device [090c:1000] "SMI Corporation, USB DISK" at address 3
2016-09-27 10:44:13 INFO :fe80::2c34:b804:bc1d:f3d7 connected
2016-09-27 10:44:16 INFO :fe80::7d1b:5a57:b5a6:7753 connected
2016-09-27 10:44:18 INFO :Unmanaging device 3 [090c:1000]
2016-09-27 10:44:25 INFO :fe80::bdbe:c5f6:dfb0:c5d connected
2016-09-27 10:44:25 INFO :fe80::1488:fb93:298a:1a33 connected
2016-09-27 10:44:28 INFO :fe80::c4ec:69a7:8c0c:a754 connected
2016-09-27 10:44:28 INFO :fe80::fdd3:fe1b:a4b3:f1d1 connected
2016-09-27 10:44:29 INFO :fe80::7491:91db:ac26:e586 connected
2016-09-27 10:44:32 INFO :fe80::3c09:7e47:3da4:d5be connected
2016-09-27 10:44:32 INFO :fe80::c058:b68c:22bb:f040 connected
2016-09-27 10:44:33 INFO :fe80::31a7:3aa1:9155:a520 connected
2016-09-27 10:44:40 INFO :fe80::c959:64f9:ae1b:dee7 connected
2016-09-27 10:44:44 INFO :fe80::5d2c:128:1372:aca8 connected
2016-09-27 10:44:44 INFO :fe80::cc63:f0b2:d9e9:6197 connected
2016-09-27 10:44:45 INFO :fe80::ec86:125a:cc0:dfa6 connected
2016-09-27 10:44:50 INFO :fe80::5828:6690:8d18:9588 connected
2016-09-27 10:44:57 INFO :Installing driver for class HIDClass {745A17A0-74D3-11D0-B6FE-00A0C90F57DA}
2016-09-27 10:45:03 INFO :OK driver installed try again...
2016-09-27 10:45:04 ERROR :DiInstallDevice failed, The name is already in use as either a service name or a service display name. (0x00000436)
2016-09-27 10:45:04 ERROR :Error binding device 24 [096e:0006] to connection 15, BIND_ERROR
2016-09-27 10:45:20 INFO :Installing driver for class USB {00000000-0000-0000-0000-000000000000}
2016-09-27 10:45:26 INFO :OK driver installed try again...
2016-09-27 10:45:32 ERROR :DiInstallDevice failed, The name is already in use as either a service name or a service display name. (0x00000436)
2016-09-27 10:45:32 ERROR :Error binding device 21 [0529:0001] to connection 15, BIND_ERROR
2016-09-27 10:48:21 ERROR :DiInstallDevice failed, The name is already in use as either a service name or a service display name. (0x00000436)
2016-09-27 10:48:21 ERROR :Error binding device 21 [0529:0001] to connection 11, BIND_ERROR
2016-09-27 10:48:25 INFO :Connection 1 successfully removed (reason:server shutdown)
2016-09-27 10:48:25 INFO :Connection 2 successfully removed (reason:server shutdown)
2016-09-27 10:48:25 INFO :Connection 3 successfully removed (reason:server shutdown)
2016-09-27 10:48:25 INFO :Connection 4 successfully removed (reason:server shutdown)
2016-09-27 10:48:25 INFO :Connection 5 successfully removed (reason:server shutdown)
2016-09-27 10:48:25 INFO :Connection 6 successfully removed (reason:server shutdown)
2016-09-27 10:48:25 INFO :Connection 7 successfully removed (reason:server shutdown)
2016-09-27 10:48:25 INFO :Connection 8 successfully removed (reason:server shutdown)
2016-09-27 10:48:25 INFO :Connection 9 successfully removed (reason:server shutdown)
2016-09-27 10:48:25 INFO :Connection 10 successfully removed (reason:server shutdown)
2016-09-27 10:48:25 INFO :Connection 11 successfully removed (reason:server shutdown)
2016-09-27 10:48:25 INFO :Connection 12 successfully removed (reason:server shutdown)
2016-09-27 10:48:25 INFO :Connection 13 successfully removed (reason:server shutdown)
2016-09-27 10:48:25 INFO :Connection 14 successfully removed (reason:server shutdown)
2016-09-27 10:48:25 INFO :Connection 15 successfully removed (reason:server shutdown)
2016-09-27 10:48:25 INFO :Unmanaging device 21 [0529:0001]
2016-09-27 10:48:25 INFO :Unmanaging device 1 [064f:03e9]
2016-09-27 10:48:25 INFO :Unmanaging device 22 [0a89:000c]
2016-09-27 10:48:25 INFO :Unmanaging device 23 [0529:0001]
2016-09-27 10:48:25 INFO :Unmanaging device 24 [096e:0006]
2016-09-27 10:48:25 INFO :Unmanaging device 25 [064f:03e9]
2016-09-27 10:48:26 INFO :>>> Shutdown <<<
2016-09-27 10:48:37 INFO :>>> Starting VirtualHere USB Server v3.0.6 (Built: Sep 24 2016, 09:55:46)<<<
2016-09-27 10:48:37 INFO :running uninstaller C:\PROGRA~1\DIFX\1B2DAACF6AAD5997\dpinst.exe /u C:\Windows\System32\DriverStore\FileRepository\vhsd_hidclass.inf_amd64_neutral_0eb19afdcecb17b8\vhsd_hidclass.inf /q
2016-09-27 10:48:37 ERROR :Waiting for uninstall failed, There are no more files. (0x00000012)
2016-09-27 10:48:37 INFO :running uninstaller C:\PROGRA~1\DIFX\1B2DAACF6AAD5997\dpinst.exe /u C:\Windows\System32\DriverStore\FileRepository\vhsd_usb.inf_amd64_neutral_76ba16928e988c5a\vhsd_usb.inf /q
2016-09-27 10:48:37 ERROR :Waiting for uninstall failed, There are no more files. (0x00000012)
2016-09-27 10:48:37 INFO :>>> Shutdown <<<
2016-09-27 10:49:10 INFO :>>> Starting VirtualHere USB Server v3.0.5 (Built: Sep 27 2016, 17:26:21)<<<
2016-09-27 10:49:10 INFO :Using configuration config.ini
2016-09-27 10:49:10 INFO :Server licensed to=fdac55de-f2a1-4b66-8ee1-49dfd83d33b2 max_devices=unlimited
2016-09-27 10:49:10 INFO :TCPServer starting...
2016-09-27 10:49:10 INFO :Listening on all network interfaces at port 7575 (IPv6 dual-stack)
2016-09-27 10:49:10 INFO :Registration called
2016-09-27 10:49:10 INFO :Found Low speed device [0529:0001] "AKS, HASP HL 3.25" at address 21
2016-09-27 10:49:10 INFO :Found Full speed device [064f:03e9] "WIBU-SYSTEMS AG, CodeMeter-Stick " at address 1
2016-09-27 10:49:10 INFO :Found Full speed device [0a89:000c] "Aktiv Co., Stealth III Sign" at address 22
2016-09-27 10:49:10 INFO :Found Low speed device [0529:0001] "AKS, HASP HL 3.25" at address 23
2016-09-27 10:49:10 INFO :Found Low speed device [096e:0006] "OEM, HID Dongle" at address 24
2016-09-27 10:49:10 INFO :Found Full speed device [064f:03e9] "WIBU-SYSTEMS AG, CodeMeter-Stick " at address 25
2016-09-27 10:49:10 INFO :Found High speed device [090c:1000] "SMI Corporation, USB DISK" at address 3
2016-09-27 10:49:11 INFO :172.16.0.113 connected
2016-09-27 10:49:12 INFO :172.16.2.69 connected
2016-09-27 10:49:14 INFO :172.16.2.69 connected
2016-09-27 10:49:26 INFO :fe80::c959:64f9:ae1b:dee7 connected
2016-09-27 10:49:27 INFO :Connection 3 successfully removed (reason:timeout)
2016-09-27 10:49:27 INFO :fe80::1488:fb93:298a:1a33 connected
2016-09-27 10:49:27 INFO :fe80::5d2c:128:1372:aca8 connected
2016-09-27 10:49:29 INFO :fe80::c4ec:69a7:8c0c:a754 connected
2016-09-27 10:49:39 INFO :fe80::7d1b:5a57:b5a6:7753 connected
2016-09-27 10:49:39 INFO :fe80::bdbe:c5f6:dfb0:c5d connected
2016-09-27 10:49:39 INFO :fe80::cc63:f0b2:d9e9:6197 connected
2016-09-27 10:49:43 INFO :fe80::ec86:125a:cc0:dfa6 connected
2016-09-27 10:49:47 INFO :fe80::7491:91db:ac26:e586 connected
2016-09-27 10:49:48 INFO :fe80::fdd3:fe1b:a4b3:f1d1 connected
2016-09-27 10:49:48 INFO :fe80::3c09:7e47:3da4:d5be connected
2016-09-27 10:49:48 INFO :fe80::31a7:3aa1:9155:a520 connected
2016-09-27 10:49:50 INFO :fe80::c058:b68c:22bb:f040 connected
2016-09-27 10:50:55 INFO :Installing driver for class USB {00000000-0000-0000-0000-000000000000}
2016-09-27 10:51:02 INFO :OK driver installed try again...
2016-09-27 10:51:03 ERROR :DiInstallDevice failed, The name is already in use as either a service name or a service display name. (0x00000436)
2016-09-27 10:51:03 ERROR :Error binding device 21 [0529:0001] to connection 4, BIND_ERROR

I'll have to continue with 3.0.2 until I see something in the new release changelog to suggest whatever this is, has gone, however if no other users are reporting an error - which I assume they're not - we may have to look at a Windows re-install - would that affect the software license key??

Thanks again

Richard

Michael
ok ill do some more testing

ok ill do some more testing with windows 7, i have an ilok and elicenser and etoken i test with, ill see what is going on....

Michael
Ok, this should be fixed in 3

Ok, this should be fixed in 3.0.7, but if you could backup your current system before trying it. I made a change which should fix the issue.

trickyb_uk
Well, that's a bit strange...

Great work, as ever.

Using v3.0.7 - the good news is that the server is running and I can connect and use 8 of 9 dongles.

Don't know what the problem with the 9th is - possibly a dodgy connector, as it previously worked fine - but very likely a local issue.

Thanks

Richard

Log in or register to post comments