client error with win10

12 posts / 0 new
Last post
zcw159357
client error with win10

Hi,
I'm trying to get virtualhere work on win10 with my raspberrypi. But when I select my usb to use, I get a error msg,
"There was an error running the Virtual HCD Enumerator(diInstallDevice returned 0xe0000246)"
I'v tried several times and all ends up like this. Pls help.

Michael
Can you try this.

Can you try this.

start a "Command Prompt" with "Run as Administrator" then type

vhui64.exe -y

then

vhui64.exe -d

and then send me the output of that command and also see if that fixes the problem.

zcw159357
i'v tried this and the output

i'v tried this and the output seems all good....

VirtualHere -> Driver Installation
VirtualHere driver install -> Creating temporary directory H:\win8Temp\LocalTemp\vhdrivers
VirtualHere driver install -> Extracting drivers
VirtualHere driver install -> "H:\win8Temp\LocalTemp\vhdrivers\vhdrivers.exe" /T:"H:\win8Temp\LocalTemp\vhdrivers" /C /Q
VirtualHere driver install -> certutil -addstore -f "TrustedPublisher" "H:\win8Temp\LocalTemp\vhdrivers\certificate.cer"
VirtualHere driver install -> "H:\win8Temp\LocalTemp\vhdrivers\dpinsts.exe" /q /c
VirtualHere driver install -> "H:\win8Temp\LocalTemp\vhdrivers\vhenum.exe"
VirtualHere driver install -> Success

zcw159357
but it still ends up with the

but it still ends up with the same error

Michael
ok, try running it from the c

ok, try running it from the c drive instead of H:

zcw159357
change the temp directory to

change the temp directory to "%USERPROFILE%\AppData\Local\Temp" as default, still the same.

Michael
ok try this

ok try this

1. type vhui64.exe -x (that will extract the drivers)
2. Change to the directory it says and then run dpinsts.exe

and see if that works...

zcw159357
running dpinsts.exe succeeded
zcw159357
running dpinsts.exe succeeded

running dpinsts.exe succeeded. but when running vhenum.exe , that error shows up.
if i only run dpinsts.exe and then i run vhui64.exe i'll get the drive reinstall and ends up with that error.
everytime that error shows up after the drive was installed, after it pops up to ask to run vhenum.exe -3

logs:
20:08:08 INFO :VirtualHere Client 3.5.2 starting (Compiled: Mar 17 2016 20:00:37)
20:08:08 INFO :Using config at C:\Users\zcw159357\AppData\Roaming\vhui.ini
20:08:08 INFO :Using USB 3.0 driver
20:08:08 INFO :IPC available at \\.\pipe\vhclient
20:08:08 INFO :Auto-find (Bonjour) on
20:08:08 INFO :Auto-find (Bonjour SSL) on
20:10:51 INFO :No drivers found, they will be installed
20:11:01 INFO :SetupDiEnumDeviceInterfaces failed
20:11:06 INFO :SetupDiEnumDeviceInterfaces failed
20:11:06 ERROR :Hub failed to open error (0x00000103)

zcw159357
20:11:06 ERROR :Hub failed to

20:11:06 ERROR :Hub failed to open error (0x00000103)
this also says "there's no data to be used" in chinese, but seems the database this forum uses doesn't support chinese, so i had to delete the chinese msg.

Michael
.

Ok thats interesting so your windows is chinese. Im wondering if this has something to do with the driver being unable to be installed. The error you keep getting is:

(0xE0000246) Device Installer Not Ready, Cause : A class installer or a co-installer for a service cannot run because a component on which it depends did not run.

I think something is not setup correctly in your windows installation, the postings i read about this error say that a reinstall of windows fixed it. Im not sure what else you can try, i dont think the client will install on your windows unfortunately.

zcw159357
thank you very much. seems i

thank you very much. seems i had to say goodbye to the wireless controller....
don't know if it has something to do with the latest win10 update which breaks the xbox one controller driver...

Log in or register to post comments