Cant find usb server(windows) on client side (mac)

8 posts / 0 new
Last post
Wong Kang
Cant find usb server(windows) on client side (mac)

I am unable to find the USB server (running on my windows PC) on the client-side (running on my Mac). I just want to use one device only which is my keyboard (Kingston, HyperX Alloy Origins Core) so I didn't think that I need to buy the license. Am I supposed to specify which device I want to use on the server or client-side or connect only the one USB device that I want to use? Because in the server log it says registration returned an error then following with managing device 1,2,3,4 . Any help that I can get to resolve this problem will be greatly appreciated.

Here is the server log:
2022-02-09 00:03:13 INFO :>>> Starting VirtualHere USB Server v4.3.6 (Built: Feb 2 2022, 05:56:54)<<<
2022-02-09 00:03:13 INFO :Using configuration C:\Users\User\Desktop\config.ini
2022-02-09 00:03:13 INFO :Server licensed to=unlicensed max_devices=1
2022-02-09 00:03:13 INFO :Listening on all network interfaces at TCP port 7575 (IPv6 dual-stack)
2022-02-09 00:03:16 INFO :Found Full speed device [8087:0029] "0x8087, 0x0029" at address 1
2022-02-09 00:03:16 INFO :Found Full speed device [0951:16e6] "Kingston, HyperX Alloy Origins Core" at address 2
2022-02-09 00:03:16 INFO :Found Full speed device [0951:16ed] "Kingston, HyperX Cloud Alpha S" at address 3
2022-02-09 00:03:16 INFO :Found Full speed device [046d:c082] "Logitech, G403 Prodigy Wired/Wireless Gaming Mouse" at address 4
2022-02-09 00:03:24 ERROR :Registration returned an error
2022-02-09 00:08:14 INFO :Unmanaging device 1 [8087:0029]
2022-02-09 00:08:14 INFO :Unmanaging device 2 [0951:16e6]
2022-02-09 00:08:14 INFO :Unmanaging device 3 [0951:16ed]
2022-02-09 00:08:14 INFO :Unmanaging device 4 [046d:c082]
2022-02-09 00:08:16 INFO :Listening on all network interfaces at TCP port 7575 (IPv6 dual-stack)
2022-02-09 00:08:19 INFO :Found Full speed device [8087:0029] "0x8087, 0x0029" at address 1
2022-02-09 00:08:19 INFO :Found Full speed device [0951:16e6] "Kingston, HyperX Alloy Origins Core" at address 2
2022-02-09 00:08:19 INFO :Found Full speed device [0951:16ed] "Kingston, HyperX Cloud Alpha S" at address 3
2022-02-09 00:08:19 INFO :Found Full speed device [046d:c082] "Logitech, G403 Prodigy Wired/Wireless Gaming Mouse" at address 4

Michael
.

In the virtualhere client, right click USB Hubs->Specify Hubs->Add -> and put in the address of your virtualhere server.

For some reason your windows server is not allowing virtualhere to install bonjour, so Auto-Find therefore wont work and you need to manually specify the server in the client.

Wong Kang
.

Thanks for the quick response. I followed your instructions regarding specifying the server on the client-side manually, however after I do that I am still unable to find the USB server. I used the EasyFindId=EK9yti9qpboZdYRZjQBYaN that was in the config file. Am I supposed to edit the config file before booting up the server? Sorry very new to this so don't really understand some of the explanations in the FAQ sections.

What is currently in the config file:
It=1644400882
EasyFindId=EK9yti9qpboZdYRZjQBYaN
EasyFindPin=6Lhoh3
DeviceIdMap=USB\ROOT_HUB30\5&17F2DDCF&0&0,USB\VID_8087&PID_0029\6&77E73D2&0&12,12,1,USB\ROOT_HUB30\5&5477969&0&0,USB\VID_0951&PID_16E6\6&25A489A2&0&1,1,2,USB\ROOT_HUB30\5&5477969&0&0,USB\VID_0951&PID_16ED\000000000001,2,3,USB\ROOT_HUB30\5&5477969&0&0,USB\VID_046D&PID_C082\086F36693336,4,4

here is the sever log:
2022-02-09 18:01:22 INFO :>>> Starting VirtualHere USB Server v4.3.6 (Built: Feb 2 2022, 05:56:54)<<<
2022-02-09 18:01:22 INFO :Using configuration C:\Users\User\Desktop\config.ini
2022-02-09 18:01:22 INFO :Server licensed to=unlicensed max_devices=1
2022-02-09 18:01:22 INFO :Listening on all network interfaces at TCP port 7575 (IPv6 dual-stack)
2022-02-09 18:01:26 INFO :Found Full speed device [8087:0029] "0x8087, 0x0029" at address 1
2022-02-09 18:01:26 INFO :Found Full speed device [0951:16e6] "Kingston, HyperX Alloy Origins Core" at address 2
2022-02-09 18:01:26 INFO :Found Full speed device [0951:16ed] "Kingston, HyperX Cloud Alpha S" at address 3
2022-02-09 18:01:26 INFO :Found Full speed device [046d:c082] "Logitech, G403 Prodigy Wired/Wireless Gaming Mouse" at address 4
2022-02-09 18:16:12 INFO :Unmanaging device 1 [8087:0029]
2022-02-09 18:16:12 INFO :Unmanaging device 2 [0951:16e6]
2022-02-09 18:16:12 INFO :Unmanaging device 3 [0951:16ed]
2022-02-09 18:16:12 INFO :Unmanaging device 4 [046d:c082]
2022-02-09 18:16:14 INFO :Listening on all network interfaces at TCP port 7575 (IPv6 dual-stack)
2022-02-09 18:16:16 INFO :Found Full speed device [8087:0029] "0x8087, 0x0029" at address 1
2022-02-09 18:16:16 INFO :Found Full speed device [0951:16e6] "Kingston, HyperX Alloy Origins Core" at address 2
2022-02-09 18:16:16 INFO :Found Full speed device [0951:16ed] "Kingston, HyperX Cloud Alpha S" at address 3
2022-02-09 18:16:16 INFO :Found Full speed device [046d:c082] "Logitech, G403 Prodigy Wired/Wireless Gaming Mouse" at address 4

Michael
.

Just follow *exactly* the instructions here https://www.virtualhere.com/easyfind

Dont edit any config files manually as it will confuse things

Wong Kang
Hi I'm still experiencing

Hi I'm still experiencing trouble, I am unable to even reach the first step of the instructions in the link above. Maybe I misunderstood this software. Right now the USB device that I want to use on my mac is connected directly into my motherboard's USB port, does this configuration work with this software or must I connect it to a separate USB hub then to the motherboard?

I have installed the client on the PC as well and there is nothing below USB hubs so I am unable to reach the server properties box. Previously you mentioned that I should try to input the server manually by specifying it in the client-side, but I cant seem to find a way to find out the server name from the server's exe file .

Sorry if these questions seem stupid, very new to this stuff.

Michael
.

You can plug the USB directly into the motherboard, no hub is needed

1. Run the virtualhere client AND virtualhere server *on the same pc*
2. In the virtualhere client right click USB Hubs->Specify Hubs->Add and put in 127.0.0.1 then press OK
3. The Windows Hub will appear then just follow the instructions at Easyfind

Then when easyfind is enabled, use that address and paste it into the remote Mac machine running the virtualhere client.

Wong Kang
The usb switch that I ordered

The usb switch that I ordered back in the beginning of Feb finally came at the start of this week so I kind of gave up on trying to get this to work. Regardless, I would like to thank you for taking the time to try to help me. I'm not sure if you are getting paid to provide support, but the service you are providing to newbies like me is truly commendable, and I doubt you get enough praise for that. So on behalf on everyone on this support forum who gotten a reply from you thank you so much.enjoy the rest of your day :).

Michael
.

Thanks for the kind words Wong Kang!

Log in or register to post comments