Client cannot install drivers

4 posts / 0 new
Last post
vlakius
Client cannot install drivers

Hi everyone,
I have a linux server running Suse Linux Enterprise 15 SP3 where i'm try to run USB Server v4.3.7 to connect 2 external USB Drive , and i have a couple of problems

1.° Problem
When i try to connect a Windows Client i cannot find automatically the HUB. There is no firewall on the server and via telnet on port 7575 everything seems fine.
Not a big deal , i inserted the hub manually and it shows my drives.

2° Problem
When a try to connect one of my drives it fails.
Here' s the system LOG
====================
2022-03-04 12:37:17 INFO :No drivers found, they will be installed
2022-03-04 12:37:17 ERROR :can't create file 'C:\Users\ADMINI~1.COO\AppData\Local\Temp\2\vhusb3hc.cat' (error 3: The system cannot find the path specified.)
2022-03-04 12:37:17 ERROR :Error 2 extracting drivers, The system cannot find the file specified.
2022-03-04 12:37:17 ERROR :File 'C:\Users\ADMINI~1.COO\AppData\Local\Temp\2\vhusb3hc.cat' couldn't be removed (error 3: The system cannot find the path specified.)
2022-03-04 12:37:17 ERROR :File 'C:\Users\ADMINI~1.COO\AppData\Local\Temp\2\vhusb3hc.inf' couldn't be removed (error 3: The system cannot find the path specified.)
2022-03-04 12:37:17 ERROR :File 'C:\Users\ADMINI~1.COO\AppData\Local\Temp\2\vhusb3hc.sys' couldn't be removed (error 3: The system cannot find the path specified.)
2022-03-04 12:37:17 INFO :SetupDiEnumDeviceInterfaces failed
2022-03-04 12:37:17 ERROR :Hub failed to open error, No more data is available. (0x00000103
======================
Tried on 2 Different Clients (Windows Server 2016 a and Windows 10 Pro ). Same result
What i checked/tried:
- Antivirus is disabled
- I tried to run it as Administrator
- Checked the SHA1SUM
- The Path C:\Users\ADMINI~1.COO\AppData\Local\Temp exists and is writeble

I wanna point out that I am using the same identical setup at other customers without any problems

Michael
.

Try changing the temp directory of windows to something simpler like c:\temp https://stackhowto.com/how-to-change-temp-folder-location-in-windows-10/

vlakius
I tried changing the NTFS

I tried changing the NTFS Permission to Everyone on the temp path with no success. Unfortunately i cannot change the temp directory.

EDIT: i "resolved" creating manually a folder named "2" in C:\Users\ADMINI~1.COO\AppData\Local\Temp.

The 1 ° problem is still there

Michael
.

Strange, I'm thinking maybe vhui64.exe doesn't have the permission to create a directory in the %TEMP% path? Anyway at least you got a work around.

Regarding Auto Find - this works by sending broadcast UDP packets on port 5353 (using the bonjour protocol) so if that is blocked then auto-find wont work and you will need to manually specify the hubs in the client.

This feature is rock solid so if its not working on your client then your windows client(s) are blocking UDP 5353 in/outbound

Log in or register to post comments