Client Cannot See Hub

4 posts / 0 new
Last post
stuart.mitchell
Client Cannot See Hub

We installed the latest version of VirtualHere hub/server on our Windows Hyper-V 2019 Core server as a service, but when running the client from another server on the same network, it cannot find it.

We've tried unregistering and re-registering the service, manually specifying the server by IP address, and adding firewall rules at both ends for port TCP 7575 and UDP 5353 both inbound and outbound.

The log just says, "Could not connect to x.x.x.x:7575".

Short of rebooting (because that will bring down a few servers we cannot afford to bring down right now) does anyone have any suggestions?

Michael
.

Yes the server wont start because it needs a GUI. Even when it runs as a service only, it needs a GUI.

stuart.mitchell
Interesting... Does that mean

Interesting... Does that mean if it's running on a normal Windows computer and that computer is not logged in with the VirtualHere server GUI open, other computers won't be able to connect to it using the client? What's the point of running it as a service if it needs the GUI open for it to work?

Michael
.

Virtualhere server can run as a service without anyone logging in with no problems on windows 10/11/2016/2019/2022 etc

However Windows core *does not include graphical features*. Graphical features are called "Desktop Experience" which is an optional add-on.

Getting USB events requires a graphical subsystem because that is how windows tells software about USB device events. This is why it is mandatory to have the "Desktop Experience" as it has all those subsystems that enable windows to function normally.

Log in or register to post comments