MacOS 12.1: USB serial device

11 posts / 0 new
Last post
apchandr
MacOS 12.1: USB serial device

Thank you for adding Support for MacOS Monterey.

I am trying to connect an Arduino Uno (a genuine one, not a clone) with VirtualHere client 5.2.7 on macOS 12.1 and server version 4.3.2 (on Debian). VirtualHere client shows I am connected to device, Arduino serial port show up (listed in /dev/tty.*) and device seen by System Information.

I am able to upload sketches like AnalogReadSerial, ReadAnalogVoltage, etc from Arduino IDE. However, when I upload CharacterAnalysis ( example sketch under Strings section) it works for sometime and stops printing the input sent from serial monitor (Serial.available becomes zero ??)

Also, I am seeing similar serial connection issues when using a different program(MATLAB) on macOS 12.1 with VirtualHere client.

Can you please advise on how to debug and troubleshoot this issue.

Michael
.

Is it possible to tell me if this works ok on a Windows 10 (or 11 Client)?

apchandr
It works fine on Windows

It works fine on Windows client on Windows 10.

Michael
.

OK I will investigate this over the next day as i have the same equipment so i can try to reproduce the issue...

Michael
.

Ive been doing some investigation.

Some Arduino boards use the ATMEGA16U as the USB->Serial adapter using this firmware https://github.com/arduino/ArduinoCore-avr/blob/master/firmwares/atmegax...

I can see that sometimes the UNO will stop responding to serial input/output via virtualhere. It uses this chip for its serial interface.

(I tested this same CharacterAnalysis test on my Arduino Pro Mini which uses an external FTDI chip instead and there are no problems)

I think the extra latency is causing this issue. I suspect its not happening in windows because of the way the driver is written for the serial device in windows.

I see there is an outstanding bug here https://github.com/arduino/ArduinoCore-avr/issues/296 for that same firmware related to corruption at higher baud rates. This script runs at only 9600 but i suspect it might be triggered by extra latency on the usb connection (as its going via the network)

For the time being i dont think ATMEGA16U based serial Arduinos will work until bugs in the serial firmware are worked out by the Arduino team.

apchandr
Thanks Michael for

Thanks Michael for investigating this issue. I am testing USB to Serial adapter and having some connection issue only on macOS ( similar to Arduino Uno), I will keep posted once I have more details.

Michael
.

Ive been investigating this further and i can see the bug in virtualhere, will let you know when its fixed...

Michael
.

OK turns out its not a bug in virtualhere but a bug in MacOS 12. Apple has confirmed and is working on a fix.... ill update this posting when a fix is available

apchandr
Thank you for looking at this

Thank you for looking at this issue.

Michael
.

OK it should be fixed now in 5.2.8 of the client available here

apchandr
Thanks for the fix. I will

Thanks for the fix. I will give a try.

Log in or register to post comments