Client drivers not installing on OSX (HighSierra, VH 4.6.1)

3 posts / 0 new
Last post
BillCorcoran
Client drivers not installing on OSX (HighSierra, VH 4.6.1)

Hi,

Couldn't find an answer to this on the forum, sorry if this is a duplicate.

Using the UI on OSX HighSierra, installation of 'osxdriver' fails. UI provides the following advice:
"The VirtualHere Client drivers could not be loaded.

Try rebooting your machine and running VirtualHere Client again."
Error dialogue:
"
12:17:28 INFO :VirtualHere Client 4.6.1 starting (Compiled: Oct 12 2018 18:52:42)
12:17:28 INFO :Using config at /Users/billcorcoran/Library/Preferences/vhui Preferences
12:17:28 INFO :IPC available at /tmp/vhclient
12:17:28 INFO :Auto-find using Bonjour - on
12:17:28 INFO :Auto-find using Bonjour SSL - on
12:17:34 INFO :No drivers installed, I am installing new ones...
12:17:36 INFO :Using OSX 10.9+ driver
12:17:45 INFO :Installed driver is now version
12:17:45 ERROR :IOIteratorNext = 0. com_virtualhere_vhhcd is not correctly registered in the kernel, please reboot and try again
12:32:29 INFO :No drivers installed, I am installing new ones...
12:32:30 INFO :Using OSX 10.9+ driver
12:32:59 INFO :Installed driver is now version
12:32:59 ERROR :IOIteratorNext = 0. com_virtualhere_vhhcd is not correctly registered in the kernel, please reboot and try again
"

Server is on a RPi3, if that makes a difference.

Have rebooted the client OSX machine, to no avail.

Any tips on a solution?

Best,
Bill

P.S. Thanks for the software! Has run great on other machines, and has been enabling USB connections (remote instrument control) over a dark fibre network in Melb. for me, so cheers!

Michael
.

Hi Bill, ok it should have shown a popup asking to Approve the driver. To try again, run the virtualhere installation again when it fails do this https://developer.apple.com/library/archive/technotes/tn2459/_index.html

BillCorcoran
Solved

Thanks Michael,
Worked as expected. An easy solve.
Best,
Bill

Log in or register to post comments