Ubuntu LTSP Odd Behavior

2 posts / 0 new
Last post
bcastellucci
Ubuntu LTSP Odd Behavior

Greetings.

Seeing slightly odd behavior with server 1.5.2 (haven't tried the latest yet, will eventually). I have a fat client running virtualhere and the machine has some assorted USB items, a multi card reader being one of them.

Virtualhere manifests it as one single device and i can use it and it does, eventually, show up on the Windows host as 4 separate drives (which is correct) however access is sloooooowwwww. And it also seems like it is continually resetting the connection (for lack of a better description) as the virtualhere client window will hang for a second or two then come back. It seems to do this every 20 or-so seconds while using this device.

If i place an SD card into the reader i can eventually mount & access the files but it takes about a minute to open up in Windows Explorer.

Below is some syslog output from the Ubuntu side.

Any thoughts?

Thanks!
Ben

Oct 4 22:02:40 ltsp228 vhusbd32: Device 14 UNBOUND from connection 1
Oct 4 22:03:03 ltsp228 vhusbd32: Device 14 BOUND to connection 1
Oct 4 22:03:24 ltsp228 kernel: [ 1004.712036] usb 1-4: reset high-speed USB device number 2 using ehci-pci
Oct 4 22:03:25 ltsp228 kernel: [ 1004.865045] usb 1-4: usbfs: process 12586 (vhusbd32) did not claim interface 0 before use
Oct 4 22:03:47 ltsp228 kernel: [ 1027.204060] usb 1-4: reset high-speed USB device number 2 using ehci-pci
Oct 4 22:03:47 ltsp228 kernel: [ 1027.378466] usb 1-4: usbfs: process 12586 (vhusbd32) did not claim interface 0 before use
Oct 4 22:06:40 ltsp228 kernel: [ 1199.988051] mce: [Hardware Error]: Machine check events logged
Oct 4 22:07:21 ltsp228 kernel: [ 1241.489400] CPU1: Core temperature above threshold, cpu clock throttled (total events = 22624)
Oct 4 22:07:21 ltsp228 kernel: [ 1241.489412] CPU0: Core temperature above threshold, cpu clock throttled (total events = 22626)
Oct 4 22:07:21 ltsp228 kernel: [ 1241.495752] CPU1: Core temperature/speed normal
Oct 4 22:07:21 ltsp228 kernel: [ 1241.495759] CPU0: Core temperature/speed normal
Oct 4 22:07:58 ltsp228 kernel: [ 1277.984057] usb 1-4: reset high-speed USB device number 2 using ehci-pci
Oct 4 22:07:58 ltsp228 kernel: [ 1278.149369] usb 1-4: usbfs: process 12586 (vhusbd32) did not claim interface 0 before use
Oct 4 22:08:19 ltsp228 kernel: [ 1298.796052] usb 1-4: reset high-speed USB device number 2 using ehci-pci
Oct 4 22:08:19 ltsp228 kernel: [ 1298.951100] usb 1-4: usbfs: process 12586 (vhusbd32) did not claim interface 0 before use
Oct 4 22:08:39 ltsp228 kernel: [ 1319.408078] usb 1-4: reset high-speed USB device number 2 using ehci-pci
Oct 4 22:08:39 ltsp228 kernel: [ 1319.555906] usb 1-4: usbfs: process 12586 (vhusbd32) did not claim interface 0 before use
Oct 4 22:09:10 ltsp228 kernel: [ 1349.988069] mce: [Hardware Error]: Machine check events logged

Michael
Could you try the latest 1.5

Could you try the latest 1.5.5 server release and 1.6.8 client release because i fixed an issue with the SET INTERFACE message and that could be your issue.

Log in or register to post comments