Opération not permited (-1)

12 posts / 0 new
Last post
seb
Opération not permited (-1)

HI,

I try to use virtual here to connect a dongle (a rockey4nd) to the client and when i try to use it i got these error messages : there was a error sharing this device" and " Error "Operation not permitted"(-1) trying to use this device.
If i try to use my keyboard or my mouse which is connect to my raspberry i got no trouble,but with this dongle i do.

I'm on raspbian on a raspberry b+ and i got the last version of virtual here.

Can someone help me please?

Michael
Take a look in /var/log

Take a look in /var/log/syslog and see what message is shows

e.g grep vhusbd /var/log/syslog

seb
Thanks for you reply

I do it and i dont really see how to troubleshoot the problem,here is my log:

56493 Sep 27 01:45:50 raspberrypi vhusbdpin: Warning, failed to send MSG_SIZE to connection 6, Broken pipe (32)
56494 Sep 27 01:45:50 raspberrypi vhusbdpin: rx:t=15,a=0,s=4
56495 Sep 27 01:45:50 raspberrypi vhusbdpin: rx:t=15,a=0,s=4
.....(lines like upper)
56505 Sep 27 01:45:53 raspberrypi kernel: [14002.260941] usb 1-1.2: reset full-speed USB device number 8 using dwc_otg
56506 Sep 27 01:45:53 raspberrypi vhusbdpin: Error -1 resetting device 0x096e/0x0007 for capture
56507 Sep 27 01:45:53 raspberrypi kernel: [14002.374517] usb 1-1.2: device firmware changed
56508 Sep 27 01:45:53 raspberrypi kernel: [14002.374911] usb 1-1.2: USB disconnect, device number 8
56509 Sep 27 01:45:53 raspberrypi vhusbdpin: Error -1 binding device 112 to connection 7
56510 Sep 27 01:45:53 raspberrypi vhusbdpin: tx:t=24,a=0,s=64
56515 Sep 27 01:45:53 raspberrypi kernel: [14002.450964] usb 1-1.2: new full-speed USB device number 9 using dwc_otg
56516 Sep 27 01:45:54 raspberrypi kernel: [14002.562802] usb 1-1.2: New USB device found, idVendor=096e, idProduct=0007
56517 Sep 27 01:45:54 raspberrypi kernel: [14002.562839] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
56518 Sep 27 01:45:54 raspberrypi kernel: [14002.562855] usb 1-1.2: Product: HID Dongle
56519 Sep 27 01:45:54 raspberrypi kernel: [14002.562869] usb 1-1.2: Manufacturer: OEM
56520 Sep 27 01:45:54 raspberrypi kernel: [14002.562882] usb 1-1.2: SerialNumber: 0049208888152C
56521 Sep 27 01:45:54 raspberrypi vhusbdpin: rx:t=10,a=0,s=0
56522 Sep 27 01:45:54 raspberrypi vhusbdpin: tx:t=11,a=0,s=0
56523 Sep 27 01:45:54 raspberrypi vhusbdpin: Unmanaging device 112
56524 Sep 27 01:45:54 raspberrypi vhusbdpin: tx:t=16,a=0,s=290
56525 Sep 27 01:45:54 raspberrypi vhusbdpin: tx:t=16,a=0,s=290
56526 Sep 27 01:45:54 raspberrypi vhusbdpin: tx:t=16,a=0,s=290
56527 Sep 27 01:45:54 raspberrypi vhusbdpin: Found Full speed device [096e:0007] "OEM, HID Dongle" at address 112
56528 Sep 27 01:45:54 raspberrypi vhusbdpin: Removing connection 6 (timeout)...
56529 Sep 27 01:45:54 raspberrypi vhusbdpin: tx:t=12,a=0,s=4
56530 Sep 27 01:45:54 raspberrypi vhusbdpin: tx:t=12,a=0,s=4
56531 Sep 27 01:45:54 raspberrypi vhusbdpin: tx:t=12,a=0,s=4
56532 Sep 27 01:45:54 raspberrypi vhusbdpin: rx:t=15,a=0,s=4
56533 Sep 27 01:45:54 raspberrypi vhusbdpin: rx:t=15,a=0,s=4
56534 Sep 27 01:45:54 raspberrypi vhusbdpin: rx:t=15,a=0,s=4
56535 Sep 27 01:45:54 raspberrypi vhusbdpin: Connection 6 successfully removed
56536 Sep 27 01:45:54 raspberrypi vhusbdpin: rx:t=10,a=0,s=0

Thanks for your help.

Michael
OK, what is happening is when

OK, what is happening is when the device is "reset" it changes is behaviour by loading new firmware inside itself.

Could you try using the device again after it has failed the first time.

If it still fails try this:

Right click the device in the virtualhere client and select "Custom Event Handler..." then type in the following line and press OK.

onReset.$VENDOR_ID$.$PRODUCT_ID$=

Then try using the device again.

seb
Still not work

I try it but it's still the same.
ANd same log execpt i can see the set of the custom event..

Michael
OK well that dongle is not

OK well that dongle is not compatible with virtualhere at the moment unfortunately.

seb
my bad

Sorry i just do a wrong copy!
now i looks like it's work,my device is "in use be me" but my software dont recognize my dongle.
Maybe my dongle is juste imcompatible with your software?

Thank again

Michael
Yes i think it is

Yes i think it is incompatible

seb
no luck

Ok thank you for your reply.

seb
it's work

After trying again and again it's finally works without any other configuration except the event handler,so yo ucan consider this dongle compatible with your soft!
Thank you.

Michael
Wow, thanks for the feedback,

Wow, thanks for the feedback, that is surprising im really glad its working for you now!

7cuShmid3
Confirmed

I confirm the random "Operation Not Permitted(-1)" errors when using FCDPP using BeagleBoneBlack/am335x server (TI website version) and Ubuntu 14.04 client (kernel 3.13 64bit). Repeated tries usually make it work, else a re-plug of the dongle should. Also noticed that waiting for 5 seconds before trying again increases probability of success.

Log in or register to post comments